3. ANSYS Workbenchの基本的な使用方法

3.1. 概要

ここでは、ANSYS Workbench上でStatic Structural解析を行う場合を例として、Workbenchの基本的な使用方法について解説します。
ANSYS Workbenchを起動すると下記の画面が表示されます。

Toolboxのリストから使用したいソフトウェアをダブルクリックすると、Project Schematicに解析システム(テーブル)が起動します。 下記はStatic Stracturalの解析システムを起動した画面です。

各項目のステータスは以下の通りです。
設定済み

記号 状態名 詳細
Unfulfilled 上流にデータがない状態。上流のセルの操作が必要
Attention Required このセルに対し何らかの操作が必要な状態
Reflesh Required 上流のデータに変更があったため更新が必要な状態
Update Required 更新が未完了な状態
Up to Date 設定が完了した状態

セルがすべてUp To Dateの状態になるようにセルの上流からGeometry、Models、Setup、Solution、Resultsの順に操作を行っていきます。

Geometry Editerを開き、モデルを作成します。Geometry Editerとして以下が使用可能です。

Linux版: DesignModelerのみ
Windows版: DedignModeler, SpaceClaim direct Modeler

Geometryセルを右クリックし、New DesignModelerをクリックすると、DesignModelerが起動します。

モデルの作成が完了すると、GeometryステータスがUp to Dateになります。

この要領で、Model、Setup、Solution、Resultsの順に操作を行っていきます。

[View]-[Files]をクリックすると、作成されたファイルを確認できます。

3.2. 使用例(Fluent)

ここでは、流体解析(Fluent)を例に計算の進め方に関する概要を説明します。 その他の解析例はマニュアルをご参照ください。

3.2.1. 計算の流れ

モデル作成から、ジョブ実行、結果表示までの一連のフローは次の通りとなっています。

項目 使用するツール
ANSYS Workbenchの起動 ANSYS Workbench
流体解析システムの作成 ANSYS Workbench
流体解析モデルの構築 ANSYS DesignModeler
メッシュ作成 ANSYS Meshing
解析条件の設定・計算の実行・解析 ANSYS Fluent

3.2.2. ANSYS Workbenchの起動

ANSYS Workbenchを起動し、Toolboxビューワー(左ペイン)のField Flow (Fluent) をダブルクリックします。 すると、Project SchematicビューワーにField Flow (Fluent) というラベルの解析システム(テーブル)が表示されます。

3.2.3. 流体解析モデルの構築(DesignModeler)

流体解析モデルの構築を行います。
流体解析システムのGeometryを右クリックし、New DesignModeler Geometry をクリックして ANSYS Design Modelerを起動します。

Linuxの場合は、流体解析システムのGeometryを右クリックし、New Geometory をクリックして ANSYS DesignModelerを起動します。


スケールの単位を設定します。
この例ではミリ単位のモデルを構築するため、[Units] ? [Milimeter] を選択します。

形状を作成します。
まず、主管を作成します。
[Create]-[Proimitives]-[Torus] を選択します。

トーラス(主管の曲線部分)が作成されます。Tree OutlineにはTorus1という項目が追加されます。

Detail Viewにおいて、Base Y Componentを-1に設定します。

これにより、原点からトーラス先端の円形断面の中心に向かう方向ベクトルが指定されます。同様に、以下を設定します。

Angle: 90
Inner Radius: 100
Outer Radius: 200

トーラスのセグメントを作成するには、Generateボタンをクリックします。
以下のように表示されます。

次に、Extrudeボタンをクリックします。 Tree OutlineにExtrude1が追加され、Details ViewにDetails of Extrude1という項目が追加されます。

Details ViewのDetails of Extrude1のGeometryの「Not selected」の部分を選択します。 すると、「Not selected」の部分が[Apply]/[Cancel]の選択ボタンに切り替わります。 この状態で、ボタン(Faces選択モード)を選択し、モデルの上部表面を選択してApplyをクリックします。

Geometryが「1 Face」となり、選択していた面が青色表示となります。

続いて、Direction Vectorの None (Normal) をクリックします。 [Apply]/[Cancel] ボタンが表示されます。
再びボタンをクリックしてFacesモードにし、もう一度モデルの上部表面を選択し、この状態で [Apply] をクリックします。

Direction Vectorの値が「Face Normal」と表示されます。

FD1, Depth (>0) に 200 と入力してをクリックします。
Geometryで選択した面からDirection Vectorで指定したベクトル方向に高さ200mmの円筒が追加されます。

同様の操作でもう一方の面にも同じサイズの円筒を追加します。

次に、側管を作成します。
[Create]-[Primitives]-[Cylinder] を選択します。
Details Viewに追加される Details of Cylinder1の各項目の値を以下のように入力し、Generateをクリックします。

側管が作成されます。

対称性を考慮すると計算量を削減することができます。この設定を行います。
[Tools]-[Symmetry] を選択します。
Tree Outlineの XYPlane を選択します。
Details ViewのSymmetry Plane 1 の [Apply] をクリックします。Symmetry Plane 1の値が「XYPlane」となります。Generate をクリックします。

以下のように対称面が考慮されたモデルとなります。

形状を流体ボディとして指定します。
Tree Outlineの 1 Part, 1 Body > Solid を選択します。

Details ViewのBodyの値を「Solid」から「Fluid」に変更します。
Fluid/Solid の値を「Fluid」に変更します。

Generate をクリックします。

ANSYS DesignModeler を閉じます。
流体解析システムのGeometryセルのステータスが「?」からレ点に更新されていることを確認します。

3.2.4. メッシュの作成(ANSYS Meshing)

流体解析システムのMeshセルをダブルクリックするか、右クリックし [Edit] を選択します。

Geometryで作成した構造が自動的にロードされます。

Named Selectionを作成します。 対称性を考慮したモデルの場合はNamed Selectionを設定する必要があります。モデル構造の広い入口部分を選択します。すると選択した面が緑色に表示されます。

さらに今度は選択した面を右クリックし、[Create Named Selection] を選択します。

Selection Nameダイアログが開きます。ここで、テキストボックスを「Selection」から「velocity-inlet-large」に変更し、OKをクリックしてダイアログを閉じます。

velocity-inlet-large という名前の Named Selectionが作成されます。

同様の操作を他の開口部と対称面に対しても行います。



次に、流体ボディのNamed Selectionを作成します。
をクリックして選択フィルタをBodyに変更し、モデルをクリックして選択します。
さらにモデルを選択した状態で右クリックし、[Create Named Selection] を選択します。

Named Selectionダイアログのテキストボックスに「Fluid」と入力し、[OK] をクリックします。

次に、メッシュ生成パラメーターを設定します。
OutlineのProject/ModelのMeshを選択します。Outlineの下ペインにDetails of “Mesh” が表示されます。

Sizingを展開し、Relevance CenterをFineに変更します。

また、Quaityを展開し、SmoothingをHighに変更します。

次に、OutlineでMeshが選択されている状態のまま、モデルを選択します。さらに右クリックし、[Insert]-[Sizing]を選択します。

OutlineにBody Sizingが表示されます。

Body Sizingを選択した状態でDetails of “Body Sizing” ? SizingのDefinition > Element Sizeに 6e-3 と入力します。

今度はOutlineでMesh を選択し、Details of “Mesh” を表示します。
Infration > Use Automatic Inflation を Program Controlledに変更します。

OutlineでMeshを右クリックし、Updateを選択します。

メッシュが作成されます。

[File]-[Close Meshing] またはウィンドウのxボタンをクリックしてウィンドウを閉じ、Workbenchに戻ります。
Meshセルにチェックが入っていることを確認します。

3.2.5. CFD解析の設定

elbow流体解析システムのSetupセルをダブルクリックし、ANSYS Fluentを起動します。 Fluent Launcherダイアログが起動します。OptionsのDouble Precisionにチェックを入れ、[OK]をクリックします。

ANSYS Fluentが起動します。

ツールバーのタブの項目(Setting Up Domain、Setting Up physics、User Defined、Solving、Postprocessing、Viewing、Parallel、Design)の操作を順に行っていきます。

[Setting Up Domain]-[Mesh]-[Units] をクリックし、Set Unitsダイアログを開きます。
Task Pageの[Units]をクリックして開くこともできます。

Quantitiesに「length」、Unitsに「mm」を選択し、[Close] をクリックします。
これでスケールがmmに変更されました。

[Setting Up Domain]-[Mesh]-[Check]より、Meshの確認を行います。

ConsoleにMeshチェックの結果が表示されます。エラーが出力されなければ問題ありません。

次に、[Setting Up Domain]-[Mesh]-[Quality]をクリックします。

Meshの品質の検証が行われ、Consoleに結果が表示されます。

次に[Setting Up Physics]-[Models]をクリックし、Energyにチェックを入れます。
[Viscous]をクリックします。

k-epsilon (2 eqn) を選択し、[OK]をクリックします。

[Setting Up Domain]-[Mesh]-[Materials]をクリックし、[Create/Edit]を選択し、Create/Edit Materials ダイアログを開きます。

Nameテキストボックスにwaterと入力の上、Propertiesを以下のように変更して[Change/Create]をクリックします。

以下のウィンドウが表示されたら[No]をクリックします。

[Close]をクリックしてCreate/Edit Materialsウィンドウを閉じます。
Treeビューの Setup > Materials > Fluid > water が追加されていることを確認します。

[Setting Up Domain]-[Mesh]-[Zones]をクリックし、[Cell Zones]を選択します。

Task PageビューにCell Zone Conditionsが表示されます。
Fluidを選択し、[Edit]をクリックします。

Fluidダイアログが表示されます。
Material Nameをairからwaterに変更し、[OK]をクリックします。

[Zones]-[Boundaries]をクリックします。

Task PageビューにBoundary Conditionsが表示されます。
velocity-inlet-largeを選択し、[Edit]をクリックします。

Velocity Inletダイアログが表示されますので、下図のように設定します。

Velocity Specification Method: Magnitude, Normal to Boundary
Velocity Magnitude(m/s): 0.4
Spacification Method: Intensity and Hydrautic Diameter
Hydraulic Diameter (mm): 100

[Thermal]タブのTemperature (k)を 293.15に変更し、[OK]をクリックしてVerocity Inletダイアログを閉じます。

同様にvelocity-inlet-smallに関しても設定を行います。

下図のように値を設定します。


同様にpressure-outletに関しても設定を行います。

3.2.6. 解析

[Solving]-[Solution]-[Methods]をクリックします。

Task PageにSolution Methodsが表示されます。
GradientにGreen-Gauss Node Basedを選択します。

[Solving]-[Reports]-[Residuals]を選択します。

Residuals Monitorsダイアログが表示されます。 Plotにチェックが入っていることを確認します。その他はデフォルトのままOKをクリックします。

[Solving]-[Reports]-[Definitions]-[New]-[Surface Report]-[Facet Maaximum]を選択します。

Surface Report Definitionダイアログが表示されます。
Nameにtemp-outlet-0と入力します。
Report File及びReport Plotにチェックを入れます。
Frequencyを3に設定します。
Field VariableドロップダウンリストからTemperature及びStatic Temperatureを選択します。
Surfacesリストのうちpressure-outletを選択します。
[OK]をクリックしてダイアログを閉じます。

Treeビューに以下の項目が追加されていることを確認します。
Solution > Report Definitions > temp-outlet-0
Solution > Monitors > Report Files > temp-outlet-0-rfile
Solution > Monitors > Report Plots > temp-outlet-0-rplot

Solution > Monitors > Report Files > temp-outlet-0-rfileをダブルクリックし、Edit Report Fileダイアログを開き、設定を確認します。

デフォルトのまま[OK]をクリックし、ダイアログを閉じます。
Solution > Monitors > Report Files > temp-outlet-0-rplotをダブルクリックし、Edit Report Plotダイアログを開き、設定を確認します。

デフォルトのまま[OK]をクリックし、ダイアログを閉じます。
[Solving]-[Initialization]において、Hybridを選択し[Initialize]をクリックします。

計算実行前に、[Solving]-[Run Calclation]-[Check Case]をクリックして設定が適切かどうかの確認を行います。

自動チェックが行われ、推奨される設定が表示されます。適用する場合は[Apply]をクリックします。

[Calculate]計算を実行します。


計算が完了すると「Calculation complete」と表示されます。




3.2.7. ファイルの確認

ANSYS Workbenchによって生成されるファイルは、[View]-[Files]で確認できます。